Alpha3Cloud [WDC]: Payment processing issues
Incident Report for wdc
Resolved
Alpha3 Cloud would like to inform you that the issues we experienced with our payment processing provider no longer persist.

Please accept our sincere apologies for the inconvenience caused.

We appreciate your patience and welcome any feedback.
Posted Aug 01, 2023 - 12:51 UTC
Identified
The issue has been identified.
Posted Jul 31, 2023 - 16:18 UTC
Investigating
Alpha3Cloud would like to inform you that we are currently experiencing issues with our payment processing provider.
Please be advised that payment attempts may be unsuccessful due to the current inability of the payment processor system to handle them.

Temporarily, until the issue is resolved, credit card payments cannot be processed at our Washington DC cloud location.

We are monitoring the incident closely with our provider and will keep you informed of any updates.

Thank you very much for your understanding and patience on this matter!
Posted Jul 31, 2023 - 16:17 UTC
This incident affected: Washington DC Cloud.